Solved Execute.log - Log File Constantly Grows in Size

Discussion in 'rtorrent-Pro' started by moreChalk, Feb 12, 2020.

Loading...
  1. moreChalk
    Offline

    moreChalk Nowy użytkownik Noobie

    Joined:
    May 4, 2019
    Messages:
    2
    Local Time:
    4:41 PM
    Ratings:
    +0 / 0 / -0
    Followers:
    0
    QNAP:
    TVS-x73
    Ethernet:
    1 GbE
    TVS-x73 1 GbE
    Log file execute.log, located at /share/Rdownload/logs is constantly growing in size.
    File will grow until my machine runs out of space on Volume.

    I would like to know if there is setting that can cap the file size or not create the log file at all.
    Below is an example of the file size after only 20 mins
    2020-02-11_191843.

    95% of the log is filled with repeated entries of:
    Code (Text):
    1. PHP Warning:  stristr(): Empty needle in /share/CACHEDEV1_DATA/.qpkg/rtorrent/var/www/ui/rtorrent/plugins/plimits/limits.php on line 278
    Inspecting limits.php shows the function on line 278
    PHP:
    Select All
    1.  public function checkPublic( $trackers )
    2.         {
    3.                 foreach( $this->trackers as $trk )
    4.                         if( stristr( $trackers, $trk )!==false )
    5.                                 return(true);
    6.                 return(false);
    7.         }
    8.  
    But i am no knowledgeable enough in PHP to fix it.

    The same log picture plays out in the crash report folders /share/Rdownload/reports/crash*

    Things I have attempted so far:
    1. Launching rtorrent-Pro and then deleting execute.log as admin via the FAQ shell
      Pros: execute.log is not regenerated
      Cons: ruTorrent web console complains that RSS Feeds cannot be loaded.
      RSS Rules not honored / torrents that match rules in RSS manager are not fetched.
    2. Create a crontab entry to constantly null out the log file every minute
      Edit /etc/config/crontab and add entry
      Code (Text):
      1.  * * * * * >/share/Rdownload/logs/execute.log
      Reload config and restart
      Code (Text):
      1. crontab /etc/config/crontab && /etc/init.d/crond.sh restart
      Pros: Filesize under control, RSS feed works (no web console error message)
      Cons: Log is still writing to disk constantly.

    Let me know if there is additional settings I can try / debug I can provide that can assist in finding a solution.

    Not sure if I inadvertently edited a setting, but I thought I had done a clean install of the package on my NAS.

    Firmware version: 4.4.1.1146 2019/12/06
    Model name: QNAP TVS-473
    rtorrent-Pro 0.9.7-0912
     
  2. Silas Mariusz
    Offline

    Silas Mariusz SysOp Administrator

    Joined:
    Apr 5, 2008
    Messages:
    7,647
    Local Time:
    10:41 PM
    Ratings:
    +1,646 / 32 / -7
    Followers:
    31
    QNAP:
    TS-x77
    Ethernet:
    1 GbE
    TS-x77 1 GbE
    This method is wrong.

    Its better to disable execute logging at all or disable plimits plugins.
    1. Disable execute logs
      • Open to edit: /usr/bin/rtorrent/etc/rtorrent.conf.tpl/config.tpl

      • Find:
        log.execute = (cat, (cfg.logs), "execute.log")

      • Comment this line
        # log.execute = (cat, (cfg.logs), "execute.log")

      • Save and regenerate config using UI settings
        upload_2020-2-12_7-12-42.
    2. Disable plimits plugin
      (The plug-in is intended for restrict upload on public trackers.)
      • Code (Bash):
        1. cd /usr/bin/rtorrent/var/www/ui/rtorrent/plugins
        2. mv plimits ../plugins.notused
    BTW: plimits plugin in future releases will be removed.
    Since some users complained about low seed speed while using public trackers - LOL
     
  3. moreChalk
    Offline

    moreChalk Nowy użytkownik Noobie

    Joined:
    May 4, 2019
    Messages:
    2
    Local Time:
    4:41 PM
    Ratings:
    +0 / 0 / -0
    Followers:
    0
    QNAP:
    TVS-x73
    Ethernet:
    1 GbE
    TVS-x73 1 GbE
    Perfect -- Thank you for the config location and plugin folder.

    Issue resolved.